Discussion:
Maemo Flasher-3.5 Tool Beta for Fremantle and Diablo released
(too old to reply)
J***@nokia.com
2009-06-30 12:41:11 UTC
Permalink
The Maemo Eclipse Integration 2nd Edition project has released installation packages for Maemo Flasher-3.5 Tool Beta for Linuxes, Mac OS X and Windows. Maemo Flasher-3.5 tool supports flashing of N8x0 Diablo devices and coming Fremantle devices.


Maemo Flasher-3.5 Tool details

- Version: 2.4.5.3 - Beta
- Date: June 30, 2009
- Hardware supported: Nokia N800, N810 and N810 Wimax with Diablo 4.1.x and Nokia NXXX with Fremantle 5.x


Supported operating systems

- Linuxes (Debian installation package available for Debian based Linuxes and tar ball for others)
- Windows XP with SP3 and Vista with SP1
- Mac OS X 10.5 Leopard


Downloads and documentation

- Flasher-3.5 downloads: http://tablets-dev.nokia.com/maemo-dev-env-downloads.php
- Flasher-3.5 documentation: <not available for this beta release>

Sources for libusb library (LGPL v2) installed as part of flasher-3.5 for Windows and Mac OS X:
- Libusb (Mac): http://pc-connectivity.garage.maemo.org/upstream/libusb-0.1.12.tar.gz
- Libusb-win32 (Win): http://pc-connectivity.garage.maemo.org/upstream/libusb-win32-src-0.1.12.1.tar.gz


Short description

The Maemo Flasher-3.5 Tool is a command line utility that supports N800, N810 and N810 Wimax devices with Maemo Diablo 4.1.x platform releases and coming NXXX device with Maemo Fremantle 5.x platform release. Notice that older Maemo devices (like Nokia 770) and Maemo platform releases may require a specific flasher tool.

Flasher-3.5 is run from a Linux, Windows or Mac host computer, and it will send data and commands to the connected Maemo device over USB. Command line parameters supported by flasher-3.5 together with some usage examples are documented in Help.txt file available from installation packages. Flasher-3.5 binary gives also command line help if it is run without any parameter or with "--set-rd-flags" or " --clear-rd-flags" parameters.


Installation

The Maemo Flasher-3.5 Tool should be installed from the installation package provided for Debian based Linuxes, Windows XP/Vista and Mac OS X. For other than Debian based Linux distributions also compressed tar file is provided.

Installation of Maemo Flasher-3.5 requires administration rights in all supported operating systems.
J***@nokia.com
2009-06-30 12:41:11 UTC
Permalink
The Maemo Eclipse Integration 2nd Edition project has released installation packages for Maemo Flasher-3.5 Tool Beta for Linuxes, Mac OS X and Windows. Maemo Flasher-3.5 tool supports flashing of N8x0 Diablo devices and coming Fremantle devices.


Maemo Flasher-3.5 Tool details

- Version: 2.4.5.3 - Beta
- Date: June 30, 2009
- Hardware supported: Nokia N800, N810 and N810 Wimax with Diablo 4.1.x and Nokia NXXX with Fremantle 5.x


Supported operating systems

- Linuxes (Debian installation package available for Debian based Linuxes and tar ball for others)
- Windows XP with SP3 and Vista with SP1
- Mac OS X 10.5 Leopard


Downloads and documentation

- Flasher-3.5 downloads: http://tablets-dev.nokia.com/maemo-dev-env-downloads.php
- Flasher-3.5 documentation: <not available for this beta release>

Sources for libusb library (LGPL v2) installed as part of flasher-3.5 for Windows and Mac OS X:
- Libusb (Mac): http://pc-connectivity.garage.maemo.org/upstream/libusb-0.1.12.tar.gz
- Libusb-win32 (Win): http://pc-connectivity.garage.maemo.org/upstream/libusb-win32-src-0.1.12.1.tar.gz


Short description

The Maemo Flasher-3.5 Tool is a command line utility that supports N800, N810 and N810 Wimax devices with Maemo Diablo 4.1.x platform releases and coming NXXX device with Maemo Fremantle 5.x platform release. Notice that older Maemo devices (like Nokia 770) and Maemo platform releases may require a specific flasher tool.

Flasher-3.5 is run from a Linux, Windows or Mac host computer, and it will send data and commands to the connected Maemo device over USB. Command line parameters supported by flasher-3.5 together with some usage examples are documented in Help.txt file available from installation packages. Flasher-3.5 binary gives also command line help if it is run without any parameter or with "--set-rd-flags" or " --clear-rd-flags" parameters.


Installation

The Maemo Flasher-3.5 Tool should be installed from the installation package provided for Debian based Linuxes, Windows XP/Vista and Mac OS X. For other than Debian based Linux distributions also compressed tar file is provided.

Installation of Maemo Flasher-3.5 requires administration rights in all supported operating systems.
Andre Klapper
2009-06-30 12:55:10 UTC
Permalink
Hi Jarmo,

your email and the download page do not mention any architectures.
Can you please add that information to the download page?
Post by J***@nokia.com
Supported operating systems
- Linuxes (Debian installation package available for Debian based
Linuxes and tar ball for others)
Only x86? Or also PPC?
Post by J***@nokia.com
- Windows XP with SP3 and Vista with SP1
- Mac OS X 10.5 Leopard
PPC and x86?

andre
--
Andre Klapper (maemo.org bugmaster)
J***@nokia.com
2009-06-30 14:45:19 UTC
Permalink
Hi,
-----Original Message-----
Sent: 30 June, 2009 15:55
Subject: Re: Maemo Flasher-3.5 Tool Beta for Fremantle and
Diablo released
Hi Jarmo,
your email and the download page do not mention any architectures.
Can you please add that information to the download page?
Sorry about that.

Only x86 and 32-bit for this beta release.

Main purpose to publish new Fremantle flashers, when there are no Fremantle devices yet available :), is to get feedback from maemo community and have true installation packages available for Eclipse Integration.

It would be great also to have GUI wrapper done for end users/developers on top of these (usable on all supported platforms Windows, Linuxes and Mac OS X :). Hint, hint ...

Cheers,
//Jarmo
Post by J***@nokia.com
Supported operating systems
- Linuxes (Debian installation package available for Debian based
Linuxes and tar ball for others)
Only x86? Or also PPC?
Post by J***@nokia.com
- Windows XP with SP3 and Vista with SP1
- Mac OS X 10.5 Leopard
PPC and x86?
andre
--
Andre Klapper (maemo.org bugmaster)
J***@nokia.com
2009-07-01 08:21:11 UTC
Permalink
Hi,
Post by Andre Klapper
your email and the download page do not mention any architectures.
Can you please add that information to the download page?
We just updated Flasher-3.5 download page and readme file here http://tablets-dev.nokia.com/maemo-dev-env-downloads.php

With binary architecture information flasher-3.5 beta installation packages support.

Thanks about feedback so far.

I have updated my flasher backlog with request to have also PPC architecture supported for Mac OS X. If we find PPC Mac somewhere I think this can be done easily for final release.

I have not tested Windows version in Windows 7 RC yet. If somebody has latest Win7 RC installed I would be interested are there some problems?

Cheers,
//Jarmo
J***@nokia.com
2009-07-01 06:43:08 UTC
Permalink
Hi,
-----Original Message-----
Sent: 01 July, 2009 03:05
Diablo released
Post by J***@nokia.com
The Maemo Eclipse Integration 2nd Edition project has
released installation packages for Maemo Flasher-3.5 Tool Beta
for Linuxes, Mac OS X and Windows. Maemo Flasher-3.5 tool
supports flashing of N8x0 Diablo devices and coming Fremantle devices.
One step forward and two steps back.
Happy to see that you considered this Beta release to be at least one step forward (before ending up being one step backward :)
No PPC binary, and the installer will happily chug right along
without telling users that they're installing something they
can't even use.
Only x86 and 32-bit support with this beta release. Could you explain in more detailed your installation problems. E.g. do you try to install Windows XP or Windows Vista or Mac OS X 10.x or Debian Linux or some other Linux or ...

Or are you trying to install Mac flasher-3.5 to PPC Mac? I do not Mac myself well enoug to say if architecture can be defined to the Mac installation package so that you will get some sensible error message if you try to install "wrong" architecture binary.

Cheers,
//Jarmo
gary liquid
2009-07-01 12:57:58 UTC
Permalink
is it possible to do tablet->tablet flashing?

(serious question)

most of us now have more than one device and since not all of us have linux
or windows available (hiya GA), having a native solution would be a possible
quicker workaround

gary
Post by J***@nokia.com
Post by J***@nokia.com
One step forward and two steps back.
Happy to see that you considered this Beta release to be at least one
step forward (before ending up being one step backward :)
It's hardly every anything else with Nokia. :(
Post by J***@nokia.com
No PPC binary, and the installer will happily chug right along
without telling users that they're installing something they
can't even use.
Only x86 and 32-bit support with this beta release. Could you explain in
more detailed your installation problems. E.g. do you try to install Windows
XP or Windows Vista or Mac OS X 10.x or Debian Linux or some other Linux or
...
I don't use Windows, and, by and large, I don't use Linux.
Post by J***@nokia.com
Or are you trying to install Mac flasher-3.5 to PPC Mac? I do not Mac
myself well enoug to say if architecture can be defined to the Mac
installation package so that you will get some sensible error message if you
try to install "wrong" architecture binary.
Yes, because PPC OS X is basically the only thing I have access to on
a regular basis. Yes, you can tell the installer that it should check
the architecture. No, you shouldn't be doing that because you should
be compiling a PPC binary.
_______________________________________________
maemo-developers mailing list
https://lists.maemo.org/mailman/listinfo/maemo-developers
J***@nokia.com
2009-07-01 14:28:08 UTC
Permalink
Hi,

[jot] some answers below...
________________________________
From: ext gary liquid [mailto:***@gmail.com]
Sent: 01 July, 2009 15:58
To: Ryan Abel
Cc: Tikka Jarmo (Nokia-D/Helsinki); maemo-***@maemo.org; maemo-***@maemo.org
Subject: Re: Maemo Flasher-3.5 Tool Beta for Fremantle and Diablo released

is it possible to do tablet->tablet flashing?

(serious question)

[jot] I think it is not possible because Tablet USB port drivers do not support it but I am not sure. What is possible is to use /usr/sbin/fiasco_flasher available from Tablet to flash images from mmc card.

most of us now have more than one device and since not all of us have linux or windows available (hiya GA), having a native solution would be a possible quicker workaround

[jot] The easies way to do flashing we be from PC but maybe it would be enough for you to flash from inside Tablet. BTW no quarantine this will work as I have not tested this myself.

Cheers,
//Jarmo

gary

J***@nokia.com
2009-07-01 14:17:15 UTC
Permalink
Hi,

I found something to comment from this last email :).
access to on a regular basis. Yes, you can tell the installer
that it should check the architecture. No, you shouldn't be
If same installer can be used to install both x86 and PCC binaries depending on which PC you run installation package that would be great. Anyhow I think we can make at least separate PCC installation package when we will have PCC Mac to make it.
that it should check the architecture. No, you shouldn't be
doing that because you should be compiling a PPC binary.
Nobody has told me if PCC binary can be build on x86 Mac. If not it will take some time to make PCC version of flasher-3.5 even when it is just rebuilding (at least in theory it should be just rebuilding task).

Cheers,
//Jarmo
-----Original Message-----
Sent: 01 July, 2009 15:37
To: Tikka Jarmo (Nokia-D/Helsinki)
Subject: Re: Maemo Flasher-3.5 Tool Beta for Fremantle and
Diablo released
Post by J***@nokia.com
One step forward and two steps back.
Happy to see that you considered this Beta release to be at
least one
Post by J***@nokia.com
step forward (before ending up being one step backward :)
It's hardly every anything else with Nokia. :(
Post by J***@nokia.com
No PPC binary, and the installer will happily chug right
along without
Post by J***@nokia.com
telling users that they're installing something they can't even use.
Only x86 and 32-bit support with this beta release. Could
you explain in more detailed your installation problems. E.g.
do you try to install Windows XP or Windows Vista or Mac OS X
10.x or Debian Linux or some other Linux or ...
I don't use Windows, and, by and large, I don't use Linux.
Post by J***@nokia.com
Or are you trying to install Mac flasher-3.5 to PPC Mac? I
do not Mac myself well enoug to say if architecture can be
defined to the Mac installation package so that you will get
some sensible error message if you try to install "wrong"
architecture binary.
Yes, because PPC OS X is basically the only thing I have
access to on a regular basis. Yes, you can tell the installer
that it should check the architecture. No, you shouldn't be
doing that because you should be compiling a PPC binary.
Continue reading on narkive:
Loading...